The News

A alternative PSK31 transceiver

PSK TRXIt's been a while since I updated my site. Not because there where no hobby activities; there were just too many... But this one I want you to know about. Within our club (PI4RAZ) we decided to do a winterproject, and the choice was a build-it-yourself PSK31 transceiver, using KD1JV's design.

 

 

 

 

If you want to read the original article, you will find it HERE. It looked pretty well-cooked: everything was there. The design, even a component layout which we used to reverse-engineere the PCB. Comparing the PCB with the schematic, we found a lot of errors. So Hugo PA2HW drawed the PCB all over in his PCB design software.

At that point we decided to build 3 prototypes, just to see whether the project was feasible. Partslists were created, and components ordered at Mouser, Conrad and Kits & Parts. After all the components were installed, it was time for the smoke test.

A speaker was connected to the LM386 which makes adjusting easier. The BFO trimmer C24 was adjusted so that white noise was visible up to 3000Hz on the waterfall. Then a transceiver was connected to a dummy load and tuned to produce a tone in the receiver, and then T1 was tuned to maximum output. Then, the transceiver was set to 14071kHz in CW and the tuning trimmer C18 was set in such a way that there was a line visible at 1000Hz on the waterfall.

So far so good. Time to test the transmitter. A computer was connected to the audio input, and a dummyload was connected to the transceiver´s output. It did produce a rumble in the receiver, but nothing readable on the screen. Checking with the scope showed that the squarer did not work, and hence the phase flipflop produced no output either. This was caused by the DC offset of the input signal. Once the lower part of the signal exceeded 0,1V (the level set by R14 and R16), the squarer did not work anymore. Lowering the input signal caused the squarer to work again, but then the signal was so low, that the VOX fell off and there was no RF anymore...

The solution for this problem was a clamp circuit as used in old televisions:

Clamo

Whatever the input level will be, the lowest level of the signal will always be at -0.7V. Now the clamp and the phase flipflop worked. But there was by far not enough LF gain to drive the transmitter with a smartphone or tablet. If you have a look at Stevens version 1 of the transceiver, you will notice that the LF gain is 22 (R1/R3 at U2c). But in version 2 there is no LF gain at all: during the positive half of the signal the gain is 1 due to full feedback via D8. And during the negative half, the gain is unlimited due to the absence of feedback. That causes the opamp to clamp to the negative supply voltage, and because the slew rate is not that good, it takes some time to get back to normal operation. So we decided to modify the input circuit as well, according to this design:

opamp rectifier

 

The gain during the positive half of the input signal is now R2/R1, while the gain during the negative half of the signal is now 1, due to diode D2. This improves the input sensitivity a lot. Let's have a look at the input signal:

Input

 

And this is the output after the redesigned first stage:

Filtered

 

Another issue that we had to address was the very long time it took the transceiver to switch back from TX to RX after a transmission. This was due to the RC-time of R9 and C33: 1M and 10uF cause about 10 seconds "hang" time, way too much for operational use. So we changed R9 to 220k and that was a lot better.

Testing with a few fellow hams showed yet another problem: While trying to "zero beat" on a station, the actual offset was about 100Hz as what you would expect from the SPOT line! What we figured, is that the SPOT circuit caused the difference in frequency. When SPOT is ON, +5V is directly applied to the supply pin of U7. But when in transmit mode, the voltage is +5V minus the saturation voltage of Q2 minus the forward voltage of D1, leaving only 4.23V for the SA612. That is outside its specification (starting at 4.5V), and the difference in voltage probably causes the internal oscillator to shift 100Hz between TX and SPOT. So we added an extra transistor solely for the purpose of switching the power to U7; via a diode to the MUTE rail (drain of Q5) for TX and with a switch to ground for SPOT.

But that did not entirely solve the problem... There still was a 30Hz difference between SPOT and TX. What we noticed, was that at the end of the transmission, where there is no DSB signal but only a tone, the frequency audibly shifted during that period. What was the problem? At the end of the period, the squarer stops switching which reduces the load on the power supply somewhat. The negative supply is derived from a simple switcher, generating both the -3.5V for the opamps and the +Vtune. Because of the reduced load, the voltage rises a little, causing +Vtune to rise also - and that causes the 30Hz shift...

The solution here was a separate circuit for the +Vtune. Just a simple zener is not good enough, because fluctuations of the supply voltage might cause FM on the output frequency. So we used another transistor as a current source, as follows:

Current source

 

Vtune is taken from the collector/zener/capacitor. This solved all problems with the tuning: when putting the spot over the line of a CQ-ing station on the waterfall results in being exactly on frequency during transmit. Only nobody was returning  on my signal: even the hams in our club were not able to decode the signal. Now what? Measuring the output signal showed a weird signal:

Weird

 

No wonder nobody was able to copy this signal... When switching to the dummy load, the signal looked OK. What was wrong this time? Well, the problem is that there is no DC path to ground at the antenna connection. If your antenna does not provide a DC path, there is none. Since the output of the BS170s has a strong DC component, the signal is distorted if the DC cannot go anywhere. See the output on the BS170s:

Output

 

After adding a 1mH choke across the antenna terminals, the output was looking great. And my first QSO was with SP3SLO, running only 2 Watts! Now we're getting somewhere. At this time, the PCB was a mess with all kinds of corrections and additions, so we did a complete redesign of the PCB.

Prototype

 

There was one more problem to cover. Sometimes, the SPOT would provide a barely visible line on the waterfall: you would need to disconnect the antenna to even see it. But sometimes there was a big red line. Why? Finally, we found out why: it depends on how the phase flipflop stopped... If it stops with Q=0, you get the thin line. But if Q=1, the 1 on pins 4 and 10 of the unpowered 7486 flows through the protection diodes to the +TX supply rail, causing about 1.6V there. Enough for Q4 and Q6 to amplify the RF signal, causing a much thicker SPOT line. To have a permanent thick line, we disconnected pin 6 (the SET input) of the phase flipflop from groud and connected it through 10k to the +5V. Now pin 6 is connected to the unused terminal (NC) of the SPDT SPOT switch, so it is connected to ground again when SPOT is not in use. But when you activate SPOT, the SET input of the phase flipflop is connected to +5V and sets Q to 1, so we have always a very visible SPOT line now...

Time for some additions. There were no potmeters in the original design. But when using my smartphone, the volume was adjustable in only 8 steps (0-7), where the difference between step 6 and 7 was less than 1W and overdrive. So 2 10k potmeters were added for both input and output, where the output potmeter also provides a DC path for the smartphone's MIC input, which causes it to think an external mic is connected, thus disabling its internal mic. Works like a charm.

Furthermore, we added a simple Wattmeter. This design was a toy kit, powered by a button cell to act as a gimmick in the disco. With some redesign, it is a perfect Wattmeter:

Wattmeter

 

The input is connected to the antenna bus, and the signal is rectified by D25 and D26. If you adjust VR1 so that D19 (the yellow LED) just starts to light up when your Wattmeter reads 3W, the other LEDs represent the following values: D16 (green) =0.5W, D17 (green) =1W, D18 (green) =2W, D19 (yellow) =3W of course, because that was our reference, and D20 (red) is about 4.3W. You can calculate that yourself by using the square of the voltage ratio with 3W as the reference. In practice, this is a very useful addition: you immediately see when the transceiver is getting too much input (the PA starts splattering, resulting in the red LED to flash) and you can easily adjust the input and output signals for optimal performance.

Of course, powering this nice little rig with batteries is logical. For the ease of checking the battery condition, we designed a battery monitor using a bi-color LED:

Batmon

 

It is a simple design: the battery voltage is fed to two comparator inputs, each driving a corresponding LED. With the given values for R44-R47 the GREEN led lights above 12V and the RED light below 13V. Thus, when the supply exceeds 13V, the LED is green, between 12 and 13V the LED is yellow, and below 12V the LED is red. Nice little indicator that performs well.

But when you use batteries, a buit-in charger becomes handy. Otherwise, you have to open the enclosure every time when you want to charge the batteries. So, we designed a switch mode power supply for charging purposes. The switcher generates about 15V, which is fed to the batteries through an diode (to protect the batteries from discharging when the switcher is off) and a 10 Ohm resistor:

Switcher

 

The maximum current is about 300mA when the batteries are fully discharged. Because at the end of the charge process the battery voltage is about 14,1V, the final current is somewhere below 20mA, which is well below 0,01C of 2700mA AA cells I use (10 of them), and that means that according to the specification of NiMH cells, this current may flow indefinitely without damaging the batteries. This also works great. But of course, you don't want this to be on when receiving, because a switch mode powersupply usually generates a lot of harmonics... So we came up with a power/switch circuit:

Switching

 

The anti-moron-rectifier D4 in the original design is put in series with the relay, so if you connect the supply wrong, nothing happens because the relay will not activate and the supply voltage can go nowhere. If there is no external power, switching the rig ON will connect the battery to the rig. Is external power supplied with the rig switched off, than the charger ("omvormer" in Dutch) charges the battery. If you switch the rig on with external power supplied, the charger is disconnected and the external power supply is connected to the rig.

For all these circuits a PCB is created; actually there are 3 now. A main TRX PCB, a PCB for the power switching and the switch mode power supply, and a front panel PCB that has the potmeters, battery monitor and the Wattmeter on it. Conrad has a nice box in which the PCB's fit nicely; if you leave the Power and Main PCB's connected together, you have 2 PCB's one on the bottom and one behind the front panel. The complete rig looks like this:

Rig

 

And does it work? Yes it does:

QSO

 

On the bottom of the picture you can see me setting the spot signal on the CQ-ing station. And it worked. Currently we provide this project as a kit, with already 34 builders (which is a lot for our small club...)

Oh, almost forgot: here is the schematic of the rig with all modifications and additions. If you want to build the rig yourself, we may have some PCBs left and we sure have the layouts.

Schematic

You are here: Home The News A alternative PSK31 transceiver